12:00:15 <nijel> #startmeeting Montly phpMyAdmin IRC meeting
12:00:16 <pmabot> Meeting started Wed Sep 14 12:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is nijel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:17 <pmabot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:19 <pmabot> The meeting name has been set to 'montly_phpmyadmin_irc_meeting'
12:01:18 <nijel> shall we wait or can we start right now?
12:01:46 <ibennetch> I'd say start now
12:01:55 <nijel> okay :-)
12:02:06 <nijel> #topic Meeting logs
12:02:29 <nijel> I guess there is not much to discuss, let's see how it works this time and we can decide if to use MeetBot or not...
12:02:52 <nijel> any questions?
12:03:15 <DevenB> This looks good. :-) Let's see how this one goes and then take a decision.
12:04:00 <nijel> #topic PMA 4.4.x EOL
12:04:19 <nijel> #info phpMyAdmin 4.4.x is only supported for security updates through October 1, 2016. Are we happy ending support at this time?
12:05:19 <nijel> by dropping support we end supporting PHP 5.3 and 5.4
12:05:40 <nijel> there is still 4.0.10.x, but that lacks support for recent MySQL versions...
12:06:06 <nijel> but I'm fine with dropping support for it (probably after making last security release with queued fixes)
12:06:12 <nijel> #save
12:06:57 <ibennetch> I agree that we should do another release before completely dropping it, and I also agree that it's time to end support for 4.4.
12:07:43 <DevenB> I don't have a strong opinion. We still occasionally (or is it very occasionally ?) get users who are stuck with these versions. But I must confess I am not very knowledgeable in this.
12:08:06 <ibennetch> It's a large burden to support and no one has really complained about the date.
12:08:34 <nijel> DevenB: I guess some of these are usually stuck with no upgrades at all, so not making releases will not make big difference to them :-)
12:08:34 <ibennetch> It's true that we need to balance users with old (but security-supported) stable distributions, or people with web hosts who refuse to upgrade.
12:09:32 <DevenB> nijel: Ah! Yes. That makes sense. If that's so, then I agree to go ahead with ending it on current schedule.
12:09:34 <ibennetch> But PHP 5.4 is no longer supported for security fixes - for approximately a year now.
12:10:20 <ibennetch> In the future, it may be helpful for us to have download statistics about how many times each version was downloaded
12:10:48 <nijel> Download stats are probably in Google Analytics...
12:11:17 <nijel> on the other side, they don't reflect number of users much (think of hosting installations or Linux distributions).
12:11:25 <ibennetch> Good point
12:11:44 <ibennetch> Anyway, I think we all seem agreed that it's time to end 4.4, right?
12:11:54 <nijel> So everybody agrees to end 4.4 as planned?
12:12:03 <DevenB> Yes.
12:12:37 <nijel> #agreed 4.4 support will end on schedule (October 1st), there will be one more release before that
12:12:48 <nijel> #topic Real life meeting in 2017
12:13:18 <nijel> any preferences for location and dates?
12:13:34 <nijel> choices we have so far (feel free to add more):
12:13:36 <nijel> FOSDEM, Brussels, Belgium, on 4 and 5 February
12:13:41 <nijel> DebConf, Montreal, Canada, from 6 to 12 August
12:13:59 <nijel> Percona Live Santa Clara 2017 might be also good fit
12:15:20 <DevenB> I don't see currently (DebConf's slightly too far into future actually) see anything blocking me for either of the two choices. But FOSDEM might be slightly difficult for me to get leaves.
12:15:43 <nijel> for me FOSDEM is conference I will most likely attend anyway, but that's not really relevant in the decision
12:18:14 <ibennetch> It's hard for me to predict my schedule that far in advance, but FOSDEM and DebConf both seem to be good fits for us.
12:18:38 <DevenB> nijel: The dates for Percona Live 2017 are April 24-27th or are they not confirmed yet ?
12:18:48 <ibennetch> FOSDEM is a bit more interesting for me, although I did quite enjoy DebConf. DebConf is closer and might fit my schedule better.
12:19:00 <nijel> also there is option to not schedule based on conferences, just meet somewhere where it would be convenient for us to travel
12:19:26 <nijel> DevenB: AFAIK dates are not yet set, but we can expect something like this
12:19:36 <ibennetch> I don't have much to say about Percona.
12:19:52 <nijel> ibennetch: it's also relatively close to you ;-)
12:20:58 <nijel> AFAIR Marc was present there several times and he quite enjoyed meeting our users there
12:23:00 <nijel> the dates might be April 10-12th (source http://www.cuandoo.com/mysql-conference-and-expo-3677.html)
12:23:15 <ibennetch> That sounds familiar. It would be good to go to Percona and interact with the database community.
12:23:52 <ibennetch> And currently that time frame is clear in my calendar, but April is a rather busy time for us, so that might change as we get closer.
12:24:25 <ibennetch> I have heard Montreal is quite nice. Perhaps Marc would join us for dinner there.
12:25:31 <nijel> I'd like to visit DebConf as well, so that option sounds interesting to me as well.
12:26:13 <DevenB> After this DebConf's experience, I would surely love to be at the DebConf next year. :-)
12:27:12 <nijel> so it seems we have preference here :-)
12:27:12 <DevenB> Also, I don't have anything planned myself for April, but again it would also slightly depend on if I get the leaves.
12:28:53 <ibennetch> It's been a few years since we've been to Percona, so I suggest that we perhaps keep both in mind -- even if only a few team members can travel to Percona, it might be good to have a presence there. Then we can plan the big meeting for DebConf.
12:29:32 <DevenB> That sounds good to me.
12:29:40 <ibennetch> Also, DebConf is quite long compared to the others - whether or not that matters for yourselves I can't say but I may not stay for the entire period.
12:29:41 <nijel> I will definitely not make it to both conferences, but I'm okay with limited presence at Percona and full meeting at DebConf
12:34:25 <nijel> does that sound okay to both of you?
12:34:47 <DevenB> Yes. That sounds okay.
12:35:02 <ibennetch> Okay, that sounds like a good plan. I'm not certain about attending Percona myself, but maybe we can keep that in mind for 2018 instead. I like the idea of attending DebConf in 2017.
12:35:29 <nijel> #agreed Team meeting will happen on DebConf, we try to have presence at Percona Live as well.
12:35:58 <nijel> that was last topic, anybody has something else in mind?
12:36:41 <ibennetch> No, I think we've covered the business for this month.
12:37:10 <ibennetch> There are some issues and pull requests that should be decided on, but I haven't gathered a list yet.
12:37:21 <ibennetch> Maybe next month :)
12:37:27 <nijel> Okay, let's do that next month
12:37:33 <DevenB> Okay.
12:37:38 <nijel> #endmeeting