12:04:59 <nijel> #startmeeting Monthly meeting 2016-12
12:05:00 <pmabot> Meeting started Wed Dec 14 12:04:59 2016 UTC and is due to finish in 60 minutes.  The chair is nijel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:05:01 <pmabot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:05:03 <pmabot> The meeting name has been set to 'monthly_meeting_2016_12'
12:05:12 <nijel> #topic The 4.7.0 release
12:05:22 <nijel> #info The original schedule expected this release to be out few months ago, but we didn't do that and probably weren't ready. But it's time to think about new schedule.
12:07:00 <nijel> I think we should really focus on getting 4.7.0 out.
12:07:35 <ibennetch> I'm glad you brought this up; when doing the 4.6.5.2 release I spent some time looking through the tracker with the same intentions.
12:08:07 <ibennetch> I really would like to see the issue regarding trouble with lower case names get some attention for 4.7.0, though.
12:08:20 <DevenB> How do we generally go about deciding this ? Do we have enough features implemented ? (I know many are out there on the issue tracker that ready to be taken up for implementation).
12:09:33 <ibennetch> https://github.com/phpmyadmin/phpmyadmin/issues/11816 is the case problem bug. I haven't looked at it in a while so I don't recall how obvious the problem is.
12:09:42 <nijel> DevenB: I don't think there is any threshold for new features. I just see that master and QA_4_6 are different enough to cause some troubles when merging them :-).
12:10:12 <ibennetch> DevenB: Generally when we feel it's ready. As nijel said, when QA_4_6 and master start to diverge is a good time from a project management perspective.
12:11:02 <nijel> ibennetch: I'd look at it, however I can't reproduce it, what makes debugging quite tricky.
12:12:02 <nijel> anyway I will give it a try and look into that ... but anyway, let's discuss the schedule rather than individual bugs :-)
12:12:12 <ibennetch> Right, thanks for keeping us on target.
12:12:46 <ibennetch> I was actually thinking if we might plan to release 4.6.6 and 4.7.0-beta around the same time, the end of January.
12:12:53 <ibennetch> THen 4.6.6 would be the last of QA_4_6
12:12:59 <nijel> 4.6.6 should be out in January, how about doing 4.7.0 alpha/beta at same time?
12:13:13 <nijel> ibennetch: okay, we seem to agree ;-)
12:13:19 <DevenB> Okay. Then I accept that we can fix some long pending and/or irritating bugs like the one ibennetch mentioned and can think of going ahead with the newer version.
12:13:58 <ibennetch> Welcome back DevenB, did you miss anything? nijel and I feel the same about releasing 4.7.0-alpha around the same time as 4.6.6, in January.
12:14:04 <nijel> #save
12:14:19 <ibennetch> In the mean time, we should also consider the tracker and tag any bugs that are blockers for 4.7.
12:14:30 <nijel> DevenB: in case you did miss something the log is here: https://irc.phpmyadmin.net/meetbot/phpmyadmin/2016/phpmyadmin.2016-12-14-12.04.log.html
12:15:06 <nijel> ibennetch: I just did that for bug you've referenced
12:15:10 <ibennetch> Thanks.
12:15:16 <DevenB> Ya. I seemed to have disconnected for sometime. Thanks for the info ibennetch. Thanks for the link nijel, was just looking for a link to the log. :-)
12:15:34 <ibennetch> Aside from merge issues, there are actually quite a few useful features in master that would be good to release.
12:16:18 <nijel> ibennetch: one quite important change is move from embedded libraries to composer managed dependencies (at least for vendors this is quite important change)
12:17:37 <nijel> What about 4.7.0 beta in January around 4.6.6, what will be last regular release in 4.6 series and final 4.7.0 in March (to follow two months release cycle)?
12:18:14 <ibennetch> Sounds pretty good;  we'll move ahead with 4.7.0-alpha in January, and depending how that goes we'll see what happens with -alpha and -beta we can decide about the release.
12:18:20 <ibennetch> But March sounds about right.
12:19:09 <nijel> DevenB: does that schedule sound okay to you?
12:19:12 <DevenB> I agree. March for the final release sounds good to me.
12:19:26 <nijel> #agreed 4.7.0 beta in January around 4.6.6, what will be last regular release in 4.6 series and final 4.7.0 in March (to follow two months release cycle)
12:19:28 <nijel> #save
12:19:40 <nijel> #topic GSoC 2017
12:19:54 <nijel> #info GSoC 2017 has been announced a while back. Do we want to participate in GSoC 2017? What would be the goals/projects ?
12:21:09 <nijel> I'd like to participate, however the question is whether we have chance to be accepted...
12:21:36 <ibennetch> I would like to participate, and I think most of the ideas from last year are still valid.
12:21:50 <nijel> I think GSoC really helps to attract new developers
12:22:14 <DevenB> I guess that would be depend on do we have enough would-be mentors available ? And the quality of projects is what Google generally shortlists I guess, isn't it ?
12:22:56 <nijel> I definitely can mentor 2 students
12:23:05 <ibennetch> Last year we didn't get in specifically because Google had changed their acceptance weighting so that projects that hadn't participated before had a better chance.
12:23:31 <ibennetch> They made it sound like we would have a good chance in the future; it wasn't anything about our organization, the just wanted to accept new projects.
12:24:42 <nijel> So we have chance unless there will be many new projects again .... hmm maybe I should apply with Weblate ;-).
12:24:44 <ibennetch> I can mentor two as well.
12:24:56 <ibennetch> It can't hurt to try :)
12:26:18 <nijel> Okay, we have at least two mentors, ideas from last year are mostly valid, so we're probably good to apply
12:26:29 <DevenB> I am not sure if I would be able to mentor a project at this point.
12:26:47 <ibennetch> We have about a month before the project applications open. There's not much to do before then, but I can update the wiki to the 2017 list.
12:27:04 <DevenB> On the other hand, technically I am still a student (doing an intern) so I might want to participate as a student if I can find some free time. I know that we accept based on quality of the proposal submitted (even for the team members)
12:27:31 <ibennetch> That's fine DevenB, we appreciate your motivation but it's definitely not expected that project members mentor (or participate :)
12:28:40 <nijel> DevenB: you're welcome to participate on either side...
12:28:51 <ibennetch> :)
12:29:11 <ibennetch> So I'll update the wiki later today, and we'll have to work on the application beginning January 19
12:29:48 <nijel> #agreed We will apply for participation in GSoC 2017
12:29:51 <nijel> #save
12:29:56 <DevenB> Yea. I just wanted to give a heads up. so that you discuss the mentoring organisation-related stuff on the separate gsoc mailing list. :-)
12:30:00 <DevenB> So that it does not become unfair for other applicants.
12:30:40 <nijel> DevenB: yes we had that setup in past as well as we had students among us several times
12:30:46 <nijel> Any other topics to discuss?
12:31:37 <ibennetch> DevenB: thanks for mentioning that; I'll also make sure the mailing list is ready.
12:32:02 <ibennetch> I think not nijel, unless you have something to say here about the wiki.
12:32:14 <ibennetch> Or if you want to keep that on the mailing list, I think we're done here.
12:32:23 <nijel> #topic Wiki
12:32:52 <nijel> I really don't have much to add besides what I've written there, but we can discuss it here...
12:34:05 <ibennetch> I think we're all stuck in a cycle of "this isn't perfect, but it's pretty good; there are alternatives but they're also not perfect"
12:34:42 <DevenB> I agree with ibennetch. :-)
12:34:45 <DevenB> Even though I have not edited much on the wiki recently, I personally find the Github UI quite accessible and edit-friendly.
12:35:01 <nijel> IMHO any alternative means much more work for us and I don't think it outweighs the benefits
12:35:49 <ibennetch> Pretty much.
12:36:12 <ibennetch> The only thing that comes close in git integration is ikiwiki
12:36:41 <ibennetch> And I don't see any advantage over the Github one.
12:37:51 <ibennetch> Well, the three of us seem to agree that we all lean slightly towards keeping github wiki.
12:38:00 <nijel> Okay, so let's stick with GitHub for now. Also let's see if somebody complains on the mailing list...
12:38:25 <nijel> #agreed Stay with GitHub wiki for now
12:38:28 <nijel> #save
12:38:29 <DevenB> Seems okay to me.
12:38:35 <nijel> Anything else to discuss? :-)
12:38:51 <ibennetch> Nothing from me.
12:38:53 <ibennetch> Thank you
12:39:18 <DevenB> Nothing from me as well.
12:39:27 <nijel> Thanks everybody for attending and enjoy Christmas :-)
12:40:03 <DevenB> Thank you everyone! Bye :-)
12:40:26 <RaghuRam__> Was here to find out about GSoC. Glad that PMA is applying. :)
12:40:30 <ibennetch> You too nijel
12:40:49 <ibennetch> RaghuRam__: Wonderful. We look forward to your application (assuming we're accepted, of course)
12:40:49 <nijel> raghuram__: That does not imply we will get accepted though...
12:40:58 <nijel> #endmeeting