12:01:35 <nijel> #startmeeting Monthly meeting 2017-03
12:01:36 <pmabot> Meeting started Wed Mar  8 12:01:35 2017 UTC and is due to finish in 60 minutes.  The chair is nijel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:37 <pmabot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:39 <pmabot> The meeting name has been set to 'monthly_meeting_2017_03'
12:01:58 <DevenB> Hi ibennetch
12:02:02 <nijel> Hello everybody
12:02:18 <ibennetch> Hi nijel
12:02:46 <nijel> shall we wait for Dan or Madhura?
12:03:51 <DevenB> I am okay with waiting for sometime.
12:04:16 <ibennetch> Sure, we can wait a few minutes.
12:09:18 <nijel> okay, let's start, in case somebody will be late he can join the discussion...
12:09:22 <nijel> #topic Supporting Conservancy
12:09:33 <nijel> #info In March 2015, we decided to support Conservancy by donating "Supporter" status for each team member; which we did in two phases (April and November). In April 2016, we elected to do this again. Do we wish to continue?
12:10:25 <nijel> I don't mind in continuing here, though we've might want to wait for fund matching (AFAIK last one was around FOSDEM).
12:12:02 <DevenB> Yeah. I feel, if we have enough funds, we can definitely continue.
12:12:35 <ibennetch> They just had a matching donation drive in February. It filled the entire match amount, so we didn't really miss anything by not giving then.
12:12:55 <ibennetch> Supporter status is $120/person.
12:13:17 <ibennetch> And we have five members.
12:13:53 <ibennetch> I'm also in favor. And their t-shirts are comfortable :)
12:15:25 <nijel> Our funds should not be problem, we're very well funded (our assets are something around $130k right now)
12:16:12 <nijel> #agreed We will get supported status for each team member
12:16:25 <nijel> #action nijel Let Bradley know about this
12:16:39 <nijel> #topic Using Gitter/Slack/whatever instead of IRC
12:17:12 <ibennetch> This doesn't interest me much.
12:17:39 <nijel> What are your preferences here? I've never used anything of these, so I'm not really experienced enough to push the decision...
12:17:47 <DevenB> I have never used Gitter much. But having used Slack, I feel Slack might be an overkill for our use-case.
12:18:11 <DevenB> And the invite-only issue is there too.
12:18:23 <ibennetch> I admit I have often thought about getting us on Slack, because we deal so rarely with each other in real-time, but it doesn't fit our needs very well.
12:18:36 <ibennetch> In particular, exactly that -- the invite only is a large barrier to entry.
12:18:39 <nijel> Also if promoting some such service, people will start to look for support there what is something we're unable to provide with current manpower...
12:18:44 <ibennetch> And we have the mailing list.
12:20:39 <DevenB> Yeah. I don't see any obvious/large downside of using our current tools.
12:20:57 <ibennetch> At this point, I see no advantage to Gitter or Slack. I vote no unless someone can give me a good reason to change.
12:21:22 <nijel> Okay, so nobody seems to in see compelling advantage to change toolings...
12:21:46 <ibennetch> We have mail for offline and IRC for online. The barrier for getting on IRC isn't that high; freenode has a web client which we might announce more aggressively if we think people are having trouble getting online.
12:22:00 <ibennetch> But really, the mailing list is where we want people to go.
12:22:33 <ibennetch> Plus, we control the archives (and anyone can archive it, too); it's not like with some hosted service where we're depending on them.
12:22:39 <nijel> We really do not use IRC for anything else than monthly meetings and I think it works perfectly well with pmabot.
12:22:53 <ibennetch> So we're all agreed?
12:23:28 <nijel> #agreed No change to existing setup.
12:23:43 <nijel> #topic GSoC - mentors
12:23:47 <nijel> #info Do we have more mentors than Michal and Isaac?
12:24:19 <DevenB> I might look to participate as a student actually. So count me out.
12:24:55 <nijel> Maybe Dan would be interested, but he's not here...
12:26:06 <nijel> #action nijel will write him email
12:26:34 <nijel> As there is nobody else from the team here, I think we're done with this point :-).
12:26:41 <nijel> #topic GSoC - mentor money
12:26:47 <nijel> #info Will we distribute the mentorship money to mentors as in past years?
12:28:13 <ibennetch> This is fine with me.
12:28:23 <DevenB> Since the organization has enough sponsorship funds, I don't see any compelling reason to not do it. I vote in favor.
12:28:35 <nijel> I agree as well.
12:28:55 <nijel> #agreed Mentors will get the mentorship money from Google.
12:29:07 <nijel> #topic Improve table structure tab
12:29:17 <nijel> #info Isaac is looking for developer input about the "Proposed ideas" and "Needs decision" sections of the proposal to improve the table structure tab?
12:29:27 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/projects/1
12:31:15 <ibennetch> Ah, yes, any thoughts about this?
12:31:32 <ibennetch> In particular,
12:31:43 <ibennetch> Do we agree to rename "Improve table structure" to "Normalize"?
12:31:51 <nijel> I think pretty much everything makes sense, I think this page is result of adding features over years and nobody considering it's overall look...
12:32:37 <ibennetch> And what do you think about the "Needs decision" box on that page - adding several tabs?
12:33:08 <nijel> As I've proposed this in the original issue, I think it's good idea ;-)
12:33:34 <ibennetch> I also agree
12:33:35 <DevenB> Yeah. Normalize might make more sense. Since we are suggesting ways to achieve the higher NFs through this UI feature (which ultimately helps to improve Table structure). *Please correct me if I am wrong here.
12:33:55 <ibennetch> Exactly.
12:34:41 <ibennetch> I'm not sure what was meant by "Adding indexes should be a single button/link", this is already only a few clicks if a user accepts the defaults.
12:35:51 <DevenB> And I agree about adding secondary tabs on Table Structure page. I too feel it would make it more consistent.
12:35:58 <ibennetch> Should this target 4.8?
12:36:14 <ibennetch> (It's clearly too late for 4.7)
12:36:16 <nijel> Yes, good idea
12:37:03 <ibennetch> (Or is that too much of a change for an 4.x version?)
12:38:31 <ibennetch> Okay, anyway, as long as we agree these changes are headed in the right direction, we can continue to work out details in the issue that's attached to it.
12:38:43 <ibennetch> I don't want to hold us up too much with details here.
12:39:30 <nijel> #agreed This seems to be good direction to improve look of the page
12:39:46 <nijel> #topic Roadmap to 4.7
12:39:55 <nijel> #info Let's hear from Isaac about the path towards 4.7. Will we release an -rc1? Are there any blocking issues?
12:40:34 <nijel> I don't see any blockers and I'd like to see another beta/rc out soon.
12:40:59 <ibennetch> I'm planning rc1 for today
12:41:15 <ibennetch> Basically I added this to the agenda just to update you all on this.
12:41:46 <nijel> Great :-)
12:44:40 <ibennetch> I also don't see any big blockers.
12:45:17 <nijel> #agreed There will be rc1 released today and we don't see any blockers right now.
12:45:38 <nijel> #topic Issues: OpenSSL error
12:45:41 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12924
12:46:30 <ibennetch> I may have added this issue to the list before it was closed.
12:46:36 <nijel> I think showing the error was (my) bad decision as it was only appearing after bug in our code. This is really not something we should show to the users.
12:46:36 <ibennetch> Looking at it now.
12:47:02 <ibennetch> Yes, this is old
12:47:05 <ibennetch> Let's move on
12:47:08 <ibennetch> Sorry about that
12:47:18 <nijel> #topic Issues: Export SQL uses \r\n
12:47:25 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12930
12:47:58 <ibennetch> If this is valid, it might block 4.7 IMHO
12:48:41 <DevenB> I was not able to reproduce this actually.
12:50:15 <nijel> Indeed, the question is how to reproduce it ...
12:51:27 <DevenB> Like I can reproduce that the export contains '\r\n'; but as Isaac commented on the issue, that's what is done by mysqldump too.
12:51:43 <ibennetch> I feel this is the expected behavior, so I don't even know what to do with this report.
12:52:19 <ibennetch> I vote to close it as such
12:52:35 <nijel> I thought the problem was that he gets \\r\\n in the export...
12:52:52 <ibennetch> Good comment there nijel about asking him/her for both exports
12:53:01 <nijel> Anyway I've asked him to provide dumps showing the issue, hopefully that will help us understand what is going on...
12:53:14 <ibennetch> Let's leave it for now and see what the response is
12:53:32 <nijel> #topic Issues: Phalanger/peachpie compatibility
12:53:38 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12773
12:54:51 <ibennetch> I just vote to close this. We don't claim to support it, and I think that's what this is about
12:55:17 <ibennetch> It's great that phalanger tested against phpMyAdmin, but we don't have the resources to test or maintain this compatibility.
12:55:26 <nijel> I agree to close this, still anybody can contribute patches
12:55:39 <ibennetch> We write PHP code, if an interpreter or compiler breaks it's more likely a bug with that than us.
12:56:30 <DevenB> Yeah. We would welcome patches related to this, but don't feel like going out of way to add support for this.
12:57:05 <nijel> Well it might be useful for us - it could identify some problematic pieces of the code (same as PHP 7.2 discovers wrong using of count() on non arrays), but I still don't think this is something we should focus on, we have more important issues to solve.
12:57:31 <ibennetch> Good point
12:57:57 <nijel> #agreed Close this with note that patches are always welcome.
12:58:07 <nijel> #topic Issues: Field names in Excel exporter
12:58:11 <ibennetch> Does anyone feel a need to change the header default for Excel export? I feel changing it could break user expectations, but probably having it enabled makes more sense in the end.
12:58:14 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12951
12:59:04 <nijel> I don't have strong opinion on this, I'm fine with either options. Anyway if we're going to change the defaults, it should be done prior to rc1 IMHO.
12:59:15 <ibennetch> My feeling exactly
13:00:08 <DevenB> I also don't have a strong opinion on changing the default but am open to it anyway.
13:00:26 <nijel> The time is running out, there are two more issues to discuss. Is everybody fine with continuing?
13:00:29 <ibennetch> So with three neutral views, what do we do?
13:00:31 <ibennetch> I can continue
13:01:13 <DevenB> I can continue for sometime too.
13:02:01 <nijel> What is use case for excel export? If people want to load the data into spreadsheet, they most likely want the field names there...
13:02:42 <ibennetch> That is a good point, and that sort of sways me to thinking we should make the change.
13:03:05 <ibennetch> That's good enough for me :) Let's make the change.
13:03:17 <nijel> #agreed Let's change the default
13:03:26 <nijel> ibennetch: will you do that?
13:03:54 <ibennetch> Sure
13:03:58 <nijel> #action ibennetch will implement the change
13:04:02 <nijel> #topic Issues: Remove lines to free up space
13:04:08 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12833
13:05:13 <ibennetch> Is this worth leaving open for now?
13:05:49 <ibennetch> I think he's right, but it sounds like a compatibility change for themes.
13:05:59 <ibennetch> So maybe for 4.8 or 5.0
13:06:15 <nijel> I'd like to avoid additional complexity for themes this would introduce. I think creating themes is already hard enough....
13:06:20 <ibennetch> Yes
13:06:36 <DevenB> Yeah. Agreed.
13:07:25 <nijel> #agreed This would add another complexity to themes, let's avoid that
13:07:37 <nijel> #topic Issues: Theme selection for future releases
13:07:42 <nijel> #info https://github.com/phpmyadmin/phpmyadmin/issues/12373
13:08:04 <nijel> I've added that during meeting, sorry for late inclusion, but I think we should face this decision...
13:09:28 <nijel> I still prefer doing what I've outlined in https://github.com/phpmyadmin/phpmyadmin/issues/12373#issuecomment-274451984
13:11:03 <ibennetch> I tend to not be a fan of a contest for the theme.
13:11:40 <nijel> I'm not sure if contest is best option, but it would certainly attract more attention to creating themes...
13:11:47 <DevenB> The timeline looks good indeed. But we might have to shift it by some weeks, since we did not announce a theme contest ?
13:12:49 <nijel> Yes, the timeline matches the time I've written it, but we first should decide whether we want to do it this way and then eventually adjust the timeline ;-)
13:16:37 <DevenB> Have we done theme contests before ? If yes, how did they turn out ?
13:18:09 <nijel> Yes we had it once and that's the theme we're using right now, see https://github.com/phpmyadmin/phpmyadmin/wiki/Theme_Contest
13:19:16 <nijel> (oh, it has been 6 years ago)
13:20:44 <DevenB> If we are still using the theme that won the for 6 straight years, then I am not against having it again. (Though I am unfamiliar with the nitty-gritty of the whole exercise as such.)
13:21:29 <nijel> I really don't recall much details from that time...
13:22:25 <nijel> I even don't have idea how many people voted as the server is no longer there...
13:22:27 <nijel> Anyway I think our current theme is showing it's age, so we should probably figure out way forward :-)
13:23:27 <ibennetch> I don't know what I think about this one.
13:23:45 <ibennetch> I'm thinking about a couple of aspects of it and it would be nice to have more themes available.
13:24:16 <ibennetch> By the way, fallen is beautifully written; it's broken up in to several smaller .css files to make it easier to read.
13:25:05 <ibennetch> On the other hand, I'm not enthusiastic about forcing 5.0 just to get theme stability.
13:25:46 <nijel> I was thinking about change to 5.0 to indicate default theme change (as that is something what all users would notice)
13:26:00 <ibennetch> Ah yes, that makes complete sense.
13:27:08 <nijel> Anyway we're already 25 minutes over and we don't seem to be getting to some conclusion, so let's postpone this to next time (and possibly discuss in the issue tracker)?
13:28:36 <ibennetch> Sure, that makes the most sense.
13:29:02 <nijel> Okay, thanks to everybody for participating and see you next time ;-)
13:29:19 <DevenB> Thank you everyone! See you next month! :-)
13:31:47 <nijel> #endmeeting