12:00:15 <nijel> #startmeeting Monthly meeting 2017-04
12:00:16 <pmabot> Meeting started Wed Apr 12 12:00:15 2017 UTC and is due to finish in 60 minutes.  The chair is nijel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:17 <pmabot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:19 <pmabot> The meeting name has been set to 'monthly_meeting_2017_04'
12:00:31 <nijel> Hello everybody, I think it's time to start meeting :-)
12:00:55 <nijel> we don't have much topic, so hopefully it will be fast meeting...
12:00:58 <nijel> #topic Themes selection
12:01:35 <nijel> This has been discussed for quite a lot time last meeting, but without any conclusion...
12:02:18 <nijel> #link https://github.com/phpmyadmin/phpmyadmin/issues/12373
12:03:00 <nijel> So first question: Do we want to change theme?
12:03:32 <ibennetch> I don't like any current theme better than pmahomme.
12:03:32 <madhuracj> I am in favor of a theme change
12:03:54 <ibennetch> I don't mind a theme change, but I don't see anything I like better right now.
12:04:34 <madhuracj> I also like pmahomme to stay
12:05:14 <nijel> I personally like mhn better than pmahomme
12:05:43 <ibennetch> I think fallen and mhn are both decent themes, but too flat -- there's too much white that it just looks like a bit wall of white text.
12:06:29 <ibennetch> Anyway, my answer to the first question is no, I don't want to change the default theme right now. I'm always open to the idea if something better comes up.
12:06:51 <madhuracj> Should it matter which two themes we ship by default as long as the users can easily get other themese?
12:07:39 <nijel> downloadable themes are nice, but it leads to problems in upgrading them together with code
12:07:49 <nijel> both on our side (we tend to ignore themes repository on themes change)
12:08:04 <nijel> and on users side (they don't realize the theme needs to be updated)
12:08:45 <ibennetch> Which might bring up a second question to decide, whether we should add another official theme to the download kit.
12:08:50 <nijel> these are solvable problems, but right now it's a bit annoying (see eg. https://github.com/phpmyadmin/phpmyadmin/issues/13167)
12:10:06 <nijel> Including additional theme might be option, but how much of themes we want to ship?
12:10:18 <madhuracj> Hmm. Anyway, about the first question, I'd  like to change the default themes, but do not feel strongly about it.
12:10:34 <madhuracj> So I am also open to additional themes.
12:10:47 <madhuracj> Three, atmost four?
12:10:52 <ibennetch> Including more themes does introduce trouble because it's hard to remove them once we add them.
12:11:01 <ibennetch> Because users will always expect "their" theme.
12:11:54 <ibennetch> I'm not sure what a good balance is between giving users options and just distributing extra 'cruft' no one uses
12:12:02 <ibennetch> (or only a few people, anyway)
12:13:33 <nijel> Another option is to make external themes easier to manage - to provide automated download and introduce theme versioning which will not allow to use incompatible themes
12:14:36 <nijel> BTW: the current additional themes have 1.5 MB to 3.7 MB
12:14:39 <ibennetch> Yes, we should do something about theme versioning; I was thinking that as well after #13167
12:14:54 <ibennetch> That's quite a large file size to include, too.
12:15:54 <nijel> So let's split it up: How much themes do you think we should ship?
12:16:30 <nijel> I think one additional is good enough. It will allow us to see if people like the change without much increasing size...
12:17:13 <madhuracj> Three is agreeable to me
12:17:24 <udan11> I am also for one additional.
12:17:30 <ibennetch> It would be nice to collect user data on which theme is being used.
12:17:37 <ibennetch> Sure, one additional theme is fine by me.
12:18:51 <udan11> Is there any way to see which theme is the most downloaded one?
12:19:14 <nijel> #agreed We seem to agree to include one additional theme
12:19:40 <nijel> udan11: this should be available in our Google Analytics, let me try if I can dig something out of that
12:22:56 <nijel> fallen and metro were most downloaded in last month, but it's really small numbers (~150, while 4.7.0 has something like 26k downloads)
12:23:27 <nijel> of course this includes only users who don't block GA, but still shows that additional themes are not used much
12:25:26 <nijel> sorry, these are actually weekly numbers, but the monthly it's quite similar (~600 metro and fallen downloads and ~55k downloads for 4.6.6 and 4.7.0)
12:29:19 <udan11> In this case, does it make sense adding an additional theme?
12:29:52 <nijel> I'm not sure, it just can mean that current way to get additional theme is too compex...
12:30:20 <udan11> Or simply they do not bother
12:30:35 <udan11> I do not think it is complex
12:30:55 <udan11> In this case, the theme downloader would help
12:32:07 <madhuracj> I'm not sure whether many users are aware of additional themes.
12:33:07 <nijel> Sorry, I have to unexpectedly leave for now, not sure if I can get back before meeting end...
12:33:13 <nijel> #save
12:33:15 <nijel> #chair ibennetch
12:33:15 <pmabot> Current chairs: ibennetch nijel
12:33:34 <nijel> ibennetch I've made you chair, so you can control the meetbot :-)
12:33:43 <ibennetch> Ok
12:34:16 <ibennetch> I agree that the problem here can be user awareness and the hassle of downloading new themes.
12:35:48 <ibennetch> I don't have a good solution for that. A theme downloader integrated in to the code would help, certainly, but isn't a good short-term solution.
12:36:13 <ibennetch> Plus, I'm doubtful about whether anyone has time or interest in working on such a project.
12:36:24 <udan11> Or they simply like the current theme and do not see any point in changing it
12:36:36 <ibennetch> right, that's definitely a possibility here.
12:36:43 <ibennetch> I think we can't know what users are thinking.
12:36:55 <udan11> Personally, I am not a big fan of all those flat themes
12:37:04 <ibennetch> I agree
12:37:17 <ibennetch> To try to get some decision here, where are we at on changing the current default theme?
12:37:42 <ibennetch> Michal said he would like to change to mhn
12:38:09 <ibennetch> I do not wish to chagne the default.
12:38:29 <udan11> Me neither.
12:39:20 <madhuracj> I do not feel strongly about changing the default. Moreover I am  not a big fan of mhn
12:39:36 <madhuracj> So, I am inclined not to change
12:39:44 <ibennetch> Okay, so sounds like no change to the default right now, then.
12:40:41 <ibennetch> As far as adding an additional theme to the download package, let's see what theme everyone would pick.
12:40:57 <ibennetch> I imagine Michal's choice would be mhn
12:41:43 <ibennetch> I'd be okay with fallen or mhn, but again I'm not a huge fan of either because they're too flat.
12:42:18 <madhuracj> I prefer fallen or metro
12:43:23 <ibennetch> Metro is a fine choice, also.
12:43:43 <udan11> Metro is like 4 themes in one because you change the colors
12:44:22 <ibennetch> Frankly, I don't see much difference between fallen, metro, and mhn other than the color used. I like that Fallen has colorful icons.
12:47:03 <ibennetch> We don't seem to be making much progress on a decision here.
12:48:20 <ibennetch> So let's at least decide officially on whether to add another theme to the download package.
12:48:37 <ibennetch> I'm neutral on the matter. It's fine to add another.
12:49:02 <madhuracj> Same here :)
12:49:11 <udan11> Me too :)
12:50:27 <ibennetch> Good
12:50:44 <ibennetch> And about which theme we should include, I've decided I'm indifferent,
12:50:59 <ibennetch> Michal prefers mhn
12:51:10 <ibennetch> madhuracj said fallen or metro
12:51:28 <ibennetch> Unless udan11 has a tie-breaking vote, we're all sort of split on the decision.
12:51:55 <udan11> I am also indifferent...
12:52:19 <udan11> I would be more inclined to choose fallen or metro
12:52:33 <udan11> Because these are the most downloaded
12:52:47 <madhuracj> udan11 Name one :)
12:53:36 <udan11> Fallen
12:53:49 <udan11> For the colourful icons :)
12:55:05 <ibennetch> I was just thinking the opposite; we have colorful icons in pmahomme and original, so if a user really wants a flat and greyscale theme maybe we should include metro for them.
12:55:28 <ibennetch> *I* like Fallen better of the two, but I'll stick with pmahomme so this isn't for me.
12:55:35 <ibennetch> Tough decisions, huh?
12:56:11 <udan11> Yup
12:56:34 <madhuracj> Yes, that make sense. So metro it is?
12:57:03 <udan11> I think so.
12:57:46 <ibennetch> Let's bounce this back to the mailing list to keep nijel in the loop, but I think we have found a solution.
12:58:13 <udan11> This sounds good
12:59:06 <ibennetch> #agreed We will not change the default theme
12:59:36 <ibennetch> #agreed We plan to add another theme to the download package: metro.
13:00:08 <ibennetch> #action ibennetch Email the rest of the team about this decision
13:00:14 <ibennetch> #save
13:00:59 <ibennetch> Okay, that's enough of that topic
13:01:37 <ibennetch> That's it from the agenda, as well.
13:01:51 <ibennetch> Thank you for coming, it's great to have good discussion.
13:02:07 <madhuracj> Thanks everyone. Bye
13:02:22 <udan11> Good bye
13:02:30 <ibennetch> #endmeeting